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Getting Started

Installing Benshaw Connect
1. If you have a previous version of Benshaw Connect installed, uninstall it from the
programs menu of your computer.
= Existing work files and reports will not be deleted by the uninstall process.
= The Benshaw Connect Event Viewer does not need to be uninstalled.
2. Install Benshaw connect by opening the provided “Setup” file.
Launching the Program
1. Choose device and connection type from this screen.
2. Settings are loaded from most recent connection attempt, simply click “connect” to
continue.

3. Click “settings” if changes are required.

View Type TRy N setings |[ comeot )

1. For some devices, multiple view types are available.
= Use “list” view to hide graphical controls and make the parameter and meter list
full screen.

= Use “graphics” view to hide the parameter list and use graphical controls only.



Connection Settings

Device Type
= MV Drive, MX2, MX3, and SG
Drive are supported.
Profile
= Different Parameter and meter
lists for some devices.
= Use “test” view to load and
display all exposed parameters
and meters.
Node Number
= For TCP connections, the node
number can always be set to 1.

= For serial connections, the node
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I Load a Value Set: | Defauts | | Saved Seftings |

Device Type: | MV Drive

Connection Type: @ TCP{Ethernet)

Mode Number: 1
TCF

IP Address:  172.29.87.10|

Port: a02

number must match the node number for the specific device and network.

IP Address

= For TCP connections only

» The default IP address for Medium Voltage Drives is 172.29.87.10 for recent releases and

192.168.1.2 for older versions.

= A full history of previously used IP addresses is available by using the dropdown arrow.



COM Port
= For Serial connections only.
= Corresponds to the port on your
computer where the serial cable
IS connected.

o Open the windows device

manager to view active ports.

Other Serial Settings
» Default values will match the
most current communication
specifications for the selected
device.
= Older MX3 devices may use no

parity instead of even parity.

-
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Load a Value Set: | Defauts | | Saved Settings |

| i
Device Type: ’MKS v] |
Profile: test

Py

Connection Type:  © TCP(Ethemnet) @ Serial

Mode Number:

Serial
COM Port:

Parity
1 Mone
Data Bits
o 7

Stop Bits
@ 1

® 15 ©

© 0dd @ Even Protocal

@ Modbus RTU

) Modbus ASCI

o) [ cac | ‘

= SG drives have a variable baud rate. Check 1/0 91 on the keypad for the current rate

Restore Connection Settings

= Clicking the “defaults” button will reset all fields to a default state.

= Click “saved settings” to reload the most recently used values.

o Different saved settings are saved for each device and for both connection types.



Connection and Load

Device Version

= On agood connection, the version number is read

from the device and a matching source file is chosen.
Loading . . . Please Wait

® If the connection fails or an unknown version is present, the user will be prompted to

select a file.

® New or updated files can be added to this folder later using File > XML Profiles.

Organize = New folder BE= 0 @

fl Ml

I ¢ Favorites * Name : Date modified Type Size i |

l B Desktop ] 810041-02-22m 7/31/2014 9:10 AM XML File 879 KB

1 18 Downloads 7] 810041-02-24. 2 - S Sa = - = |
“Z] Recent Places || 810041-02-25 xml Bad Connecticn
& OneDrive 7] 810041-02-26_xml

I ] 810041-02-27 |

4 Libraries L 17| 810041-02-28 xml =

[5 Documents =[] s10041-02-29mi Failed to Connect. Launch interface offline? i
o Music ] 810041-02-30xmnl

[ Pictures 7| 810041-02-32.xml

B Videos | 7] ConfighMVRSi(810041-02-24)
7] ConfigMVRSi(810041-02-25) E oK I [ Cancel
18 Computer ] ConfighMVRSi(310041-02-26)
£, Local Disk (C:) L |¥] ConfigMVRSi(810041-02-2T)\8
C# legacy_sites (\\uspitfs(i | ConfigMVRSi(810041-02-28_) xml 3/30/20153:37 PM XML File 134 KB
¥ info_systems (\\uspitfsl 7] MVRSi(810041-02-23).xml 11/21/2014 8:42 AM - XML File 275 KB
# Work_Instructions (e 7] MVRSi(810041-02-24).xml 3/2/2015 9:14 AM XML File 27T KB
¥ accpac (\uspitacc.rbe. 7] MVRSi(810041-02-25).ml 3/2/2015 914 AM XML File 280 KB
# common2 (\\uspitfs01. %] MVRSi(810041-02-26).xml 3/4/20151:23 PM XML File 280 KB
i nrnine? Mnenitfell rh | A AMDCHETANAT 1T AT el 2ANANTE 11,57 ARA VAN Gile 20 vo A%
File pame: 810041-02-22:0ml ~ [XMLfiles xmi) -
| Open I l Cancel ] I

Connection

Connection Options

Connect

Disconnect

= Use “connect” and “disconnect” to control View Connection Info

Scan Rate 3

when values are read from the device.

® Choose a different scan rate to change how often values are updated and manage network

traffic.



Basic Use

Identity Information

= To help distinguish between multiple open instances of Benshaw Connect, basic
identifying information appears in the title bar.

o Device type and version. MX3 Starter - 8100230208 Node THgliiy
_— —

o |IP address or serial node number.

Parameters
= Parameters are editable values that affect the behavior of the connected device.
= To edit a parameter value, double click on any parameter in the list view or press the
enter key while the desired parameter is highlighted.

o Type a value within the allowed range and

& Write Value ﬁ

click or press enter.
Mator Service Factor

Register: 40102

Range: 1.00 -1.59

Value: 118

‘ Enter ‘ | Cancel ‘

= Parameters that have been changed to values other than the default will be highlighted in

yeI low. Group Description Value Default Register
QsTOM Motor FLA 10 Arms 10 Arms 40101
Q5T 02 Motor Service Factor 115 1.15 40102
QST O3 Running Overload Enable 1:0On 1: On 40104
QST 04 Running Overload Class 10 10 40105
QST 05 Local Source 2: Serial 1: Terminal 40110
QST 06 Remote Source 1: Terminal 1: Terminal 4011



Meters

= Meters display important diagnostic information about the connected device.
= Meters have no default values and cannot be written to.
Faults and Events
= The Fault and Event tabs display information on recent events.
= These tabs are not present for all devices; a separate “Event Viewer” program is used for

medium voltage drive event logs.

Parameters | Meters | Fault Log | | Event Log
Event# Event System State Time Stamp
1 Stop Complete Faulted 73441 AM 172016
2 Stop Commanded Faulted 73441 AM 172016
3 Ho Line Stopped 7:34:40 AM 172016
4 Start Commanded Stopped 3437 AM 1TFI2016




Save Values

Reports

= Clicking Reports > Save Values will create an xml file of all data available in the list

view.

= Select any file name to generate this

xml. By default, a different folder is

used for each device type.

Run Report

| Save Values

Display Report

Import Parameters

Display Report with Meters

= Select Reports > Display Report or Reports > Display Report with Meters to generate a

graphical report of previously saved data.

= Select an xml file to generate a report html file with the same name.

= Highlighted parameter and event values will appear in the report with similar formatting

to the list view.

C [ filey///C:/Users/JColeOLeary INT/AppData/Local/Benshaw/Benshaw%20Connect/Reports/MX3%205tasy | =

Benshaw Soft Starter Settings and Events Faults
c“'ﬁ"h v‘i'l'a}ﬁﬁ OL Class:
File: MX3 #  Fault System State = ) Kilowatts Frequency Run Time Run
: Ram|
Device MX3 Starter L3 L13-11 ©
Software: 810023-02-08 0 Amp 10 volt 10
1 HNoline Stopped 0 Amp 0 Volt 0kw 166,67 He 116:0: 0.0 b
Date Recorded: 1/6/2016 2:48:50 PM 0 Amp 15 volt
0 Amp 11 volt B
Quick Start 2 Mo line Stopped 0 Amp 0 Volt 0 lew 166.67 Hz 116:0: 0.0 H
- . 0 Amp 16 Volt
Name  Description Value Default Register
0 Amp 11 valt B
QST 01 Motor FLA 10 Arms 10 Arms 40101 3 NeLine Stopped 0 Amp 0 Volt 0 kw 166.67 Hz 116:0: 0.0 0
QST 02 Mator Service Factor 115 115 20102 0 Amp 17 volt
0 Amp 11 valt
QST03 _ Running Overload Enable L:0n 1i0n 40104 4 Mo line Stopped 0 Amp 1 Volt 0 law 166.67 Hz 116:0: 0.0 H
QST04  Running Overload Class 10 10 40105 0 Amp 16 volt
QST 05  Local Source 2; Serial 1: Terminal 40110 0 Amp 11 Volt o
5 Noline Stopped 0 Amp 0 Volt 0 law 165.67 Hz 116:0: 0.0 H
QST 06 Remote Source 1: Terminal 1: Terminal 40111 0 Amp 15 valt
QST07  Initial Current 1 100 %FLA 100 %FLA 40113 0 Amp 11 valt N
QST 08 Maximum Current 1 600 %FLA 600 %FLA 40114 6 HNoline Stopped g:;gg llﬁ‘ffu‘ﬁ 0k 166.67 Hz 126:0:0.0 0
QST03  Ramp Time L 15 sec 15 sec 40115 " Ame Tovar S
QsT10 UTS Tme 20 sec 20 sec 20119 7 Mo line Stopped 0 Amp 1 volt 0 lew 166.67 Hz 116:0: 0.0 H
0 Amp 15 Volt
Control Functions 0 Amp 11 valt N
—— . 8 Noline Stopped 0 Amj 0 volt 0 kw 166,67 Hz 116:0: 0.0
Name  Description Value Default Register Pe o amp A 0
CFNOL  StartMode L: Current Ramp 1: Current Ramp 40112 T Ame 11 volt 5
M0z Ramp Tme L Seec Seec Joits s Noline stopped 0 Amp 1 volt 0 lew 166.67 Hz 116:0: 0.0 H
0 Amp 15 volt
CFN 03 Initial Current 1 100 %FLA 100 %FLA 40113
CFN 04 Maximum Current 1 500 FLA 600 %FLA 40114
Events
CFNOS _ Ramp Time 2 15 sec 15 sec 40118
CFN 06 Initial Current 2 100 %FLA 100 %FLA 40116 EventiNumbey Event EREm o Time
CFN 07 Maximum Current 2 600 %FLA 600 %FLA 40117 L Stop Complete Faulted L5236 P 1/6/2018
A os  Intel /TP T 5 o120 2 Stop Commanded Faulted 1:52:46 PM 1/6/2016
o maxTr Py pp— e 3 No Line Stopped 1:52:46 PM 1/6/2016
CRN 10 Accel Profile 0 Linear 0 Linear 20221 hd Start Commanded Stopped 1:52:43 PM 1/6/2018
T T — o o o o12e s System Pawered Up Initizlizing 9:53:36 AM 1/6/2016
e Kok evel s o0 rn e w010 [ System Powered Down Stopped 3:45:02 PM 1/4/2016

10




View Report files
= Click File > Saved Reports to view the reports file folder.
o The report files can then be copied to another location for use outside of Benshaw
Connect.

o Folders will be present for any device that has been used to generate a report.

Organize ¥ Include in library v Share with v Burn New folder == v [ @

-

Name Date modified Type

. Favorites E

Bl Desktop ., MV Drive 12/15/2015 8:34 AM  File folder
& Downloads .. MX3 Starter 1/6/2016 2:49 PM File folder
| Recent Places
& OneDrive

Import Parameters
= Parameter values stored in the report can be used to write saved values back to the
device.
o Save an xml report of the desired values.
o To revert to these values later, click Reports > Import Parameters and select the
appropriate xml file from the file explorer.
o Benshaw connect will write values to every parameter that varies from the saved

xml.

11



Graphical Controls

Main Status and Control
= Running/Stopped and other status is displayed across the top of the interface.

= When the device is configured for network control, start and stop buttons will appear next

to the status indicators.

= [= ]

e E e

Medium Voltage Drive HMI View
= For MV Drives, the left half of the screen will

duplicate data available on the HMI touch screen.

= Speed output, cell status, lockouts, and other

information is displayed on different tabs.

12



Real Time Plot

Open a Real Time Plot Window
= Click Advanced > Real Time Plot to open a new plot window.
= Alternatively, right click any parameter or meter from the list and select “Plot Value” to

open a window with that value already added.

S =S E=CR,  S——

Add Registers
* To add a register to the window, type the address into the top text field and click “Add”
» Existing values from the list view will be added with their associated names.
= This window can also be used to poll addresses not listed in the xml profile. These values

will display the address in place of a name.

13



Display Settings
» By default, the vertical range of the graph is scaled to fit new values. This range can be
adjusted manually using the “Min” and “Max” text fields.
= “Data Points” controls the number of values shown on the screen at a time, and “Update
Interval” controls the rate at which new values are added.
Individual Settings
= Chosen with the dropdown control, the “Active Meter” area displays the value and
settings for one meter at a time.
» The “Multiplier” and Y Offset” settings can be changed for each meter. When multiple
meters are displayed in the same window, these settings allow the trend lines to be
vertically aligned or separated.

Save and Load

Save

= Like reports, the full plot can be saved at any time. | Load Display Settings
Enable Writes Values

» The data points can then be loaded for later analysis.
= The load feature can also be used to restore display settings only, where new values will

be read from the same meters.

14



Trouble Shooting

Error Connecting

= |f the program fails to connect on launch, the device cannot be polled for a correct

. ] . Bad Connectiun‘ u
version file, and the user will have to select one.

Failed to Connect. Launch interface offline?

o Click “Cancel” to return to the launch screen

and try again, or “OK” to continue in offline

mode and choose a file manually.

= Possible Causes:

o The selected Com Port is unavailable. Verify that your serial device is connected to
the Com Port specified in the Connection Settings.

o The Connection Settings are incorrect for the connected device. Click “Settings” to
review and change settings before reconnecting.

o Incorrect IP Address. For TCP connections, the IP address of your PC must be
compatible with the device address. Open the windows command prompt and try
pinging the device to ensure the correct IP address was Chosen.

Failed Connection (Red Connection Status)

= |n the case of a failed connection, Benshaw Connect will continue attempting to read
values and will reconnect automatically if the device becomes available.

= Upon reconnection, the Status bar will change to green and display “Connected.”

15



| Fle Comedtn Reports Adwnced Hep . commeced
= Possible Causes:

o The device is not powered.
o The selected IP Address is not correct. Try pinging the device from the windows

command prompt.

O Your computer IP Address is not compatible with the device IP address. The first
three sets of numbers must match the device. (172.29.87.X or 192.168.1.X

depending on device and version)

O The serial node number does not match. Check that the node number on the device
keypad matches connection settings.
Failed to Read Some Registers (blank values)
= Cells can be left blank if the registers are not mapped on the connected device.
o Verify that the device version matches the source file version.
= The connection may have been lost before all values could be loaded. If the indicator is

red, fixing the connection issue should cause the rest of the values to load.

Group Description Value Register
RTM 22 Output Frequency 40400
RTM 10 Motor Current 40401
RTM 21 Motor Voltage 40402
RTM 02 DC Bus Voltage 40403

Failed to Write a Parameter Value
= Make sure that the device is connected. (green “Connection Satus”)
= Allow time for the new value to load. Depending on the scan rate and number of

registers, the program could take several seconds to refresh and read the new value.

16



» For SG drives, a limiting parameter might be affecting the range. For example, the drive
will not allow frequency parameters to exceed the Maximum frequency at register
437406, even if the listed range is greater.

= Check version compatibility; if an incorrect xml profile was chosen, the actual enforced

range may differ from the displayed value.

17



